Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-17-2017, 04:00 PM   #1
New Camper
 
jimtwin's Avatar
 
Join Date: Nov 2016
Location: Ohio
Posts: 4
LED lights fickering when water pump is running

Hello,


We have noticed when we are running the water pump our LED lights flicker. They only do this when we are running water and the pump is on. I'm sure its inference from the pump. Has anyone else had this issue, and is there a fix. We have a 2017 33RL


Thanks
__________________
2017 Crossroads Sunset Trail 33RL
2017 Ram Rebel (Yes it has a Hemi)
2013 Harley Davidson FLHTK 110 Year Anniversary Addition.
jimtwin is offline   Reply With Quote
Old 10-18-2017, 06:53 AM   #2
Family Vacation Member
 
Join Date: Mar 2015
Location: NC
Posts: 144
I would try a fan or other 12 v gadget when the pump is running to see if you can determine any fluctuation in it. If you do, it's likely the pump motor failing or intermittently shorting, causing power fluctuations. As far as I know LED's either work or don't but can be dimmed with lower power levels. Maybe someone else has been there, done that and has a definitive answer.
__________________
2015 Crossroads Cruiser Aire CAF27RL, 2006 F350 diesel dually 4WD long bed, Trailer Saver hitch
stormseeker is offline   Reply With Quote
Old 10-18-2017, 10:21 AM   #3
Full Time Camper
 
harley's Avatar
 
Join Date: Aug 2012
Location: Belle River , Ontario
Posts: 1,391
Are you on shore power or just running off the battery? If on battery and it is low ,the lights will flicker a bit when pump comes on.
__________________


It was a rainy few days at Algonquin Prov park...tarps kept us dry.
Wayne --Belle River (Windsor), Ontario
2013 Sunset Trail Reserve 25RB..
2015 White Chev Silverado 2500HD 4x4 (6.0 l gasser)
1997 Lance SL 185 Truck Camper (for Yukon/Alaska NWT trip for 2015)
harley is offline   Reply With Quote
Old 10-21-2017, 09:57 PM   #4
Weekend Camper
 
Join Date: Sep 2017
Location: IL
Posts: 14
I have the exact same problem with my 2013 25rb .... the leds under my kitchen cabinets flickers and my leds on my awning do it as well but the rest is fine. My brother in law is a electrician and he is supposed to come look at it some time.
kginder is offline   Reply With Quote
Old 10-22-2017, 10:43 AM   #5
Weekend Camper
 
Join Date: Aug 2014
Location: Texas
Posts: 84
My idiot light for the water pump, works when it feels like it. On and off all the time, but pump works all the time. I'm guessing, glitch with light built into switch. The lights for elec and gas hot water heater always work....... switches are the same... glitch I guess
__________________
Greg and Criss
Pflugerville, Tx
2016 F-250 Powerstroke
2011 27' RLX
gregtx is offline   Reply With Quote
Old 11-03-2017, 04:43 PM   #6
Weekend Camper
 
Join Date: Mar 2016
Location: TN
Posts: 13
Agree with battery info. I had similar problem, low battery.
__________________
Sunset trail 250 RB
blingo is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 01:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.