Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-01-2010, 02:08 PM   #1
Weekend Camper
 
oldman's Avatar
 
Join Date: Dec 2008
Location: Oakdale, MN
Posts: 84
Major problem today.

Flushed water system today, turned on pump, nothing, checked wires at pump, 13.66 volts, pump inards were clean, pump would not run, pulled pump, tested on truck 12 volt battery, pump works perfectly, rechecked wiring - tested 13.66 volts again (converter online), but could not get wires to spark even on a dead short, thus voltage but no amperage to run pump.

Any ideas - we are going camping next weekend. Everything worked fine when I winterized the system.
__________________
Doug, Linda, & Murphy T. (Basset Hound)Oakdale,MN

2009 CrossRoads Seville VF35RL

2000 Ford F-350 Cr
oldman is offline   Reply With Quote
Old 05-01-2010, 04:35 PM   #2
Full Time Camper
 
Stan's Avatar
 
Join Date: Apr 2006
Location: Oak Harbor, WA
Posts: 1,969
What about the ground. Try grounding the pump with a new wire. Maybe the ground wire is broken somewhere.
__________________
Stan and Terri
Oak Harbor, WA
2008 Chevy 2500HD D/A
2007 Cruiser CF30SK
Glide Ride Pin Box
Reese 16K Slider
Stan is offline   Reply With Quote
Old 05-03-2010, 01:49 PM   #3
Family Vacation Member
 
Join Date: Apr 2009
Location: calgary
Posts: 100
I second the ground theory.
albianne is offline   Reply With Quote
Old 05-04-2010, 03:17 AM   #4
Weekend Camper
 
oldman's Avatar
 
Join Date: Dec 2008
Location: Oakdale, MN
Posts: 84
Took the trailer back to PleasureLand RV in Ramsey MN.
Found out that when they installed the new switch under warranty, that it was installed wired incorrectly. The voltage coming thru to pump was what had passed thru lighted portion of switch only! Swapped the wires at switch and all worked perfectly.
Attention to detail is the issue I have with PleasureLand RV. This has been one of many. They have made all correct, but the time lost and travel expense is excessive.
__________________
Doug, Linda, & Murphy T. (Basset Hound)Oakdale,MN

2009 CrossRoads Seville VF35RL

2000 Ford F-350 Cr
oldman is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 06:52 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.